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Learning to “Drive” Using the Keyboard HINT

1When you first learn to “drive”
a software program, it is usu-
ally easiest to use the mouse.
As you become more of an
expert user, however, it can
often be faster to use the key-
board to execute commands.
Also, heavy software users who
rely too much on mouse opera-
tions run the risk of developing
repetitive strain injuries.

The HP Advanced Design Sys-
tem has many built-in hot keys
(Alt+f , for example, opens the
File menu), and you can cus-
tomize hot keys to perform
operations that you use fre-
quently.

In the Options  menu of the
Main window or of a design
window, the command
Menu/Toolbar Configuration
opens the Customization dia-
log box where you can custom-
ize both hot keys and the tool
bar configuration. In the Main
window, you can customize
Main window operations; in a
design window, you can cus-
tomize hot keys for that type of
design (schematic and layout
are set independently).

Hot key suggestions for editing
schematics:

f for View All

d for Redraw View

z for Zoom Area

2 for Zoom Out x2

e for Edit Component Param.

t for Draw (insert) Text

w for Component Wire (draw-
ing wires between components)

m for Move & Disconnect (in
most cases, this is preferable to
the Move command, which
causes wires to remain con-
nected)

ctrl+o  for View/ Push Into Hier-
archy

Use F7 to launch simulations,
and the escape key to termi-
nate commands.

F5 moves component text.
After moving a component, it
remains selected. To deselect
it, just click on a blank spot in
the schematic.

Figure 1. Setting Schematic Hot Keys
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all of the *.dds files in the
example project are dis-
played.

8. Select the example.dds file
you want to display, and
open it.

9. Copy and paste desired
plots, equations, etc., from
the example.dds file into
your data display window.

Opening
an Example Schematic
from within a Project
1. In a schematic window,

choose Window > Schematic .
2. In the new Schematic win-

dow, choose File > Open .
3. In the Open Design dialog

box, click Browse .
4. Traverse the directory tree

to find the desired project
and design.

3. If you know the example
project path, you can type
it in and skip the remain-
ing steps. If you do not, go
to the Main window and
choose File > Copy Project .

4. On the From Project: line,
click on the Examples  but-
ton and then the Browse
button.

5. Traverse the examples
directory tree until the
project that contains the
data display that you want
is entered in the Selection
field of the Copy From File
Browse dialog box.

6. Clear the Filter field of the
Open data display dialog
box.

7. Highlight the example
selection in the Copy From
File Browse dialog box, and
paste it into the Filter field
of the Open data display
dialog box. Append the suf-
fix *.dds in this field, and

When you set up a simulation, never
start from scratch if you can avoid it.
Often the fastest way to set up a simu-
lation is to copy a schematic from an
example or from another project.

You can use any saved schematic or
data display window as a template,
including those in the program’s
examples directory.

You can also open a separate schematic
window and display a schematic from
an example or a different project.

Viewing a Data Display
Use the following steps to view a data
display from an example file when you
already have a data display open:

1. In a Data Display window, choose
File > New and open a new data dis-
play window.

2. In the new data display window,
choose File > Open .

3. Define the directory, then click Filter to
display the projects in

4. Select a project,File > Copy Project

7. Keep hierarchy
in copy. 8. Copy the project.

6. Enter a name, 5. To have the copy placed in a different
directory than the original, click the desired

directory type and Browse.

Unless you specify a different directory, the copy is placed
in the same directory as the project that was copied.

2. Click Browse.

1. Click the desired directory type.

Figure 1. The Basics of Copying Files

HINT
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Using Templates or Copying
Examples for More Efficient
Simulation Set-up and Data Display
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Saving Mouse Clicks when
Opening Projects HINT

3You can have the program
reopen design windows for you
when you reopen a project:

1. In the Main Preferences
dialog box, select Save
Project Status on Exit
(default is unselected).

2. When you change projects
or exit the program, leave
the design window(s) open
that you want to see when
you reopen the project.

The next time you open the
project, the last designs that
where open will open automat-
ically, saving you several
mouse clicks.

Figure 1. Saving Open Design Windows

Select this Option
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HINT

4
Renaming Ports on Schematics
before Generating Subcircuits

Figure 1. Schematic with Named Ports

Figure 2. Symbol

Designers often use subcircuits
to keep simulation set-ups
easy to read. When you gener-
ate a symbol for a subcircuit,
you must place a port on the
schematic at any input or out-
put point, and the program
provides the ports with default
names (P1, P2, and so on).

If you change the default
names (to something more
descriptive such as Input, Out-
put, Vplus, Vminus, for exam-
ple), the names you give the
ports appear on the subcircuit
symbol when it is created. You
may have to move the names
on the symbol view so they do
not overlap, but having the
names on the symbol make it
easier to correctly wire the sub-
circuit into a higher-level cir-
cuit.
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Enabling Easy Display of Data HINT

5Using the shortest possible
variable names in a data dis-
play makes it easier to display
data when you want to change
datasets. For example, after a
harmonic balance simulation,
instead of entering the equa-
tion:

Spectrum=dBm(SmampHBtest.HB1.HB1.HB.Vout)

just enter the equation:

Spectrum=dBm(Vout)

This way, to display a spectrum
using a different dataset, all
you have to do is change the
dataset name in the default
dataset window. Using com-
plete variable names (as in the
first equation above) is neces-
sary when you want to display
the results of two different
simulations simultaneously.

Figure 1. Using Short Variable Names
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HINT

6
Efficiently Calculate
Circuit Envelope Simulation Data

Figure 1. Using an Intermediate Variable

When doing calculations with
or displaying Circuit Envelope
data, calculations are much
faster if you define an interme-
diate variable. For example, if
you simulate an amplifier with
a digitally-modulated input
signal in order to calculate the
adjacent-channel power ratio
or plot a trajectory diagram,
you must extract the resulting
fundamental frequency
component, which is a function
of time. For example, to see
the resulting output spectrum
near the fundamental fre-
quency,
use the following equations:

Voutfund=Vout[1]
Spectrum=dBm(0.5*fs(Voutfund,,,,,"Kaiser”))

Trajectory=vs(imag(Voutfund),real(Voutfund))

This will lead to faster data
display calculations than using
Vout[1]  directly in all of the
expressions.
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Using Short Cuts when
Generating Schematics HINT

7When you create a schematic,
there are a couple techniques
that can help speed things up:

1. Copy components that you
have already placed on the
schematic, rather than
placing new ones (using
the menus or palettes)
each time.

2. Enter component names
in the Component History
window. For example, type
R for resistor, and press
Enter. Then place the com-
ponent in the schematic.
You must type in the exact
name of the component you
want; remember that ADS
is case sensitive.

3. Because the Component
History window keeps a
list of the components you
place in the schematic
(after initially opening the
window), if you see that a
particular component is
already in the schematic,
you can click the
down-arrow next to the
Component History win-
dow, select the desired
component, and insert the
part in the schematic.

Figure 1. Component History Window with List of Placed Components

Click here to display the drop-down list



10

HINT

8
Replacing MDS Wire Labels and
Series IV Test Points with
Node Names

Figure 1. IF Output Schematic with Node Names

Where MDS uses wire labels to
identify node voltages that are
to be output to a dataset, and
Series IV uses test points to
identify node voltages to be
used in calculations, the
HP Advanced Design System
uses node names.

To insert a node name:

1. Either select the “node
name” icon, which looks
like a resistor with a rect-
angle below it, or choose
the command,
Component > Node Name .

2. Type in the name you
would like to attach to a
particular node.

3. Select a component pin.
When placing a node
name, you must select a
component pin. In the
HP Advanced Design Sys-
tem 1.0, you cannot place
node names on a wire,
although this is an
enhancement under con-
sideration for a future
release.

Deleting
You do not delete a node name
the same way you delete other
components. Use the menu
command:
Edit > Component > Remove
Node Name

Renaming
Once you place a node name,
you cannot edit its name. To
change the name, simply insert
a new node name with the
desired name to the same
node.
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Using New and Improved
Data Display Capabilities HINT

9Data display has been
improved over MDS and Series
IV, although not all capabilities
in MDS and Series IV are
available in the first release of
the HP Advanced Design Sys-
tem. Some nice features
include:

• You can use marker
read-outs in equations.
For example, filter band-
width or third-order inter-
cept point of a mixer can be
calculated from marker
readouts.

• You can view matrices of
data in tabular format,
two-dimensions at a time.

• To facilitate viewing
results, you can scroll
through long lists of data
and plots.

• Refer to the examples file
/Tutorial/express_meas_prj
for many interesting and
useful ways to manipulate
simulation results.

• When you run a swept sim-
ulation, such as Circuit
Envelope, the node volt-
ages and other variables
output to the dataset are
multi-dimensional. Use the
what function to see the
independent variables and
their dimensionality.

Figure 1. Plots from ConstEVM.dds
in

/examples/RF_Board/NADC_PA_prj

Figure 2. Using the what  Function
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Use Model
A basic HP Advanced Design
System use model is as follows:

1. You create a schematic and
then run a simulation,
which generates a dataset.
The dataset is written into
the data directory with a
.ds suffix.

2. You open a data display
window to view the results
of the simulation.

3. After viewing the simula-
tion results, you may save
the data display window as
a .dds file.
Some users find it easiest
to keep schematic,
dataset, and data display
names identical. This way,
it is easy to determine
which simulation set-up
was used to generate a par-
ticular data display.

HINT
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Managing Projects

HP Advanced Design System projects
are organized as shown in this exam-
ple (CDMAsrc_prj):

DataSrcTest.dds
RevLinkSrc.dds
data

DataSrcTest.ds
RevLinkSrc.ds

mom_dsn
networks

DataSrcTest.ael, etc.
RevLinkSrc.ael, etc.

synthesis
verification

There are other files as well, and they
are documented in the program manu-
als.

Simulation
 data

Designs

Momentum
 data

DSP
synthesis

DRC
data

Current
project directory

This area displays any
hierarchy in the current project.

Current directory path
The Main
window displays the directories
that are created for a new projecf

Categorizing Designs
What do you do if you decide
that the numerous schematics
in a particular project need to
be categorized into subdirecto-
ries for better organization?
The program does not allow
subdirectories in the networks
directory, so something else
must be done. Here are two
solutions:

• In the Main window, copy
the project (File > Copy
Project ), and delete
unwanted designs from the
new project (File > Delete
Design ).
To delete unwanted
datasets, use the Data Dis-
play window command
File > Delete Dataset .
If you have subcircuits that
you want to be able to
access from two projects,
but you do not want to
keep two copies, select
File > Open  then File
Include > Remove Projects
to enable you to access
designs in project B from
project A.

• Alternatively, you can cre-
ate a new project and just
copy designs from the orig-
inal project into the new
one (Copy Design  in the
Main window).
You will have to use an
operating system file man-
ager to move or copy
datasets and data display
files.

Figure 1. A Typical Directory
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The Competitive Advantage

HP EEsof ’s EDA tools are developed for
today’s designers building tomorrow’s
communications products. From DSP and
RFIC design to device modeling and
consulting services, HP EEsof offers a full
array of design tools to streamline your
product development process.

For more information, call the local HP
sales office below or the nearest listing in
your telephone directory.

United States
Hewlett-Packard Company
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tel: (305) 267-4245/4220
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tel: (852) 2599-7889
fax: (852) 2506-9233
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